Ubuntu 16.04安装搜狗输入法

更新:搜狗官方已经更新了包,现在在Ubuntu 16.04上面安装已经不会有下面提的依赖问题了。给搜狗输入法团队点赞。

昨天安装了Ubuntu 16.04之后,发现搜狗输入法竟然安装不了,报缺少fonts-droid包。最后,通过强大的网友,找到了解决方案——核心就是将搜狗官方的deb包里面的fonts-droid依赖去掉(不影响功能使用)。具体操作如下

1. 将deb解包到sogo目录:

dpkg -X ./sogoupinyin_2.0.0.0068_amd64.deb sogo/

2. 解包deb中的control信息:

dpkg -e ./sogoupinyin_2.0.0.0068_amd64.deb sogo/DEBIAN

3. 编辑control,移除Depends中的 fonts-droid:

vi ./sogo/DEBIAN/control

4. 保存后,将解包出来的文件重新打包到sogobuild目录:

dpkg-deb -b sogo/ sogobuild/

这样新的deb包就不会提示依赖fonts-droid了。

5. 最后 ,重新安装:

dpkg -i sogobuild/sogoupinyin_2.0.0.0068_amd64.deb
apt install -f

安装完成,正常运行

PS:对于只使用LTS版本的Ubuntu用户来说,从14.04 LTS版本升级到16.04 LTS变化还是很大的。倒不是说功能、界面等方面有多大。主要是一些软件包的变化。很多软件包在Ubuntu 14.04里面都是没有问题的,但升级到16.04就会有问题,因为16.04弃用了一些就版本的软件包。当然,这主要会对一些写死版本依赖的软件有影响,对于从源安装的一般没什么影响。对我来说影响最大的就是搜狗输入法(不过16.04里面自带的fcitx拼音也挺不错的)和有道词典。目前搜狗输入法的依赖问题已经解决,但是有道词典的问题还没有解决。

参考自:http://tieba.baidu.com/p/4469687312


仅有一条评论

  1. ConnieX

    I see your blog needs some fresh posts. Writing manually takes
    a lot of time, but there is tool for this boring task, type in google:
    murgrabia's tools

    ConnieX 回复

添加新评论

选择表情 captcha

友情提醒:不填或错填验证码会引起页面刷新,导致已填的评论内容丢失。

|